Some broadband connections unavailable

Incident Report for File Sanctuary

Resolved

This incident has been resolved.
Posted Nov 16, 2025 - 21:56 GMT

Update

All affected lines are back online. We're continuing to monitor for any further issues.
Posted Nov 16, 2025 - 20:06 GMT

Monitoring

A fix has been implemented and we are monitoring the results. Most of the affected lines are now back online.
Posted Nov 16, 2025 - 19:55 GMT

Investigating

We are currently investigating an issue at our Telehouse West PoP which may impact some broadband connections using this PoP.
Posted Nov 16, 2025 - 19:45 GMT
This incident affected: Broadband.