Elevated 502 errors for WordPress Hosting and Web Hosting

Incident Report for File Sanctuary

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 08, 2026 - 11:48 BST

Investigating

We are seeing elevated levels of 502 errors for sites hosted on our WordPress Hosting and Web Hosting platforms. We are currently investigating this issue.
Posted Sep 08, 2026 - 10:54 BST
This incident affects: Web Hosting / WordPress Hosting.